import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\|)(?!\\s).*?(?!\\s)(?=\\|)";
final String string = "| --------- | -------- | --------- | |propped| - | -a flashlight in one hand and a large leather-bound book (A History of Magic by Bathilda Bagshot) propped open against the pillow. | |Pointless| - | -“Witch Burning in the Fourteenth Century Was Completely Pointless — discuss.”| |unscrewed| - | -Slowly and very carefully he unscrewed the ink bottle, dipped his quill into it, and began to write,| |downtrodden| - | -For years, Aunt Petunia and Uncle Vernon had hoped that if they kept Harry as downtrodden as possible, they would be able to squash the magic out of him.| |sheets,| - | -As long as he didn’t leave spots of ink on the sheets, the Dursleys need never know that he was studying magic by night.| |flinch| - | -But he hoped she’d be back soon — she was the only living creature in this house who didn’t flinch at the sight of him.|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}