package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(http|https)://|//)?(?P<url>www.(?P<resource>facebook.com).*?/video.php\?.*?(?:(?:videos%2F(vb\.[0-9]+%2F)?|v%3D)(?P<id>[0-9]+)).*)`)
var str = `https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fbhonline%2Fvideos%2Fvb.214066990599%2F10154442915600600%2F%3Ftype%3D3&show_text=0&width=400
https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fbhonline%2Fvideos%2Fvb.214066990599%2F10154442915600600%2F%3Ftype%3D3&show_text=0&width=400
https://www.facebook.com/v2.7/plugins/video.php?app_id=113869198637480&channel=https%3A%2F%2Fstaticxx.facebook.com%2Fconnect%2Fxd_arbiter%2Fr%2FLJ9CfGDsgQ7.js%3Fversion%3D42%23cb%3Df2426abd38%26domain%3Ddevelopers.facebook.com%26origin%3Dhttps%253A%252F%252Fdevelopers.facebook.com%252Ff4a0a392c%26relation%3Dparent.parent&container_width=613&href=https%3A%2F%2Fwww.facebook.com%2Ffacebook%2Fvideos%2F10153231379946729%2F&locale=en_GB&sdk=joey&show_text=false&width=500
https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fthenewpaper%2Fvideos%2Fvb.39533052294%2F10154361380822295%2F%3Ftype%3D3&show_text=0&width=400`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}