using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\()(?:(?=(?(1).*?(?=\1)).*?\((.*))(?=(?(2).*?(?=\2)).*?\)(.*)).)+?(?>.*?(?=\1))[^(]*?(?=\2$)";
string input = @"Answer ((((((((((misery)))))))))) adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.
Answer misery adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see) day promotion. Quitting) informed concerns) can men now. Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome (((admitted.
Answer misery))) adieus add wooded how nay men before though. Pretended belonging contented mrs suffering favourite you the continual. Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}