#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([+]{1}[1-9]{1}[0-9]{0,2}[ ]{1}([1-9]{1}[0-9]{1,4}){1}[ ]{1}([1-9]{1}[0-9]{2,6}){1}([ -][0-9]{1,5})?)|([0]{1}[1-9]{1}[0-9]{1,4}[ ]{1}[0-9]{1,8}([ -][0-9]{1,8})?)?)"
Local $sString = "06429 1111" & @CRLF & _
"06901 306180" & @CRLF & _
"06429 231" & @CRLF & _
"0800 3301000" & @CRLF & _
"0179 1111111" & @CRLF & _
"0873 376461" & @CRLF & _
"03748 37682358" & @CRLF & _
"05444 347687-350" & @CRLF & _
"0764 812632-41" & @CRLF & _
"0180 2 12334" & @CRLF & _
"0800 5 23234213" & @CRLF & _
"+49 6429 1111" & @CRLF & _
"+49 39857 2530" & @CRLF & _
"+55 11 2666-0054" & @CRLF & _
"+300 11 2666-0054" & @CRLF & _
"+49 641 20106 0" & @CRLF & _
"+49 641 20106" & @CRLF & _
"+49 30 3432622-113" & @CRLF & _
"" & @CRLF & _
"------" & @CRLF & _
"" & @CRLF & _
"+300 11 0000-0000" & @CRLF & _
"(06442) 3933023" & @CRLF & _
"(02852) 5996-0" & @CRLF & _
"(042) 1818 87 9919" & @CRLF & _
"06442 / 3893023" & @CRLF & _
"06442 / 38 93 02 3" & @CRLF & _
"06442/3839023" & @CRLF & _
"042/ 88 17 890 0" & @CRLF & _
"+49 221 - 542194 79" & @CRLF & _
"+49 (221) - 542944 79" & @CRLF & _
"0 52 22 - 9 50 93 10" & @CRLF & _
"+49(0)121-79536 - 77" & @CRLF & _
"+49(0)2221-39938-113" & @CRLF & _
"+49 (0) 1739 906-44" & @CRLF & _
"+49 (173) 1799 806-44" & @CRLF & _
"0173173990644" & @CRLF & _
"0214154914479" & @CRLF & _
"01517953677" & @CRLF & _
"+491517953677" & @CRLF & _
"015777953677" & @CRLF & _
"02162 - 54 91 44 79" & @CRLF & _
"(02162) 54 91 44 79" & @CRLF & _
"saddsadasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd asdasd asd" & @CRLF & _
"asdasd" & @CRLF & _
"kjn asohas asdoiasd" & @CRLF & _
"23434 234 234 23" & @CRLF & _
"323" & @CRLF & _
"23434 234----234" & @CRLF & _
"///// ----" & @CRLF & _
"// id8834 3493934 //"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")