$re = '/^(?=.*[а-яё])(?=.*\d)[а-яё\d]+$/mui';
$str = '111
АД111
125АВАВАВ
ыва234цуёк
ГКМ
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);