$re = '/([^\/]+[^\/]|[^\/]+[\/])$/m';
$str = 'https://www.blick.ch/sport/fussball/challengeleague/
https://www.blick.ch/sport/fussball/nati/
https://www.blick.ch/life/wissen/technik/
https://f2.blick.ch/img/news/crop8290483/3393194026-chorizontal-w644-h364-q90/Daniel-Barenboim-gibt-im-April-2018-seine-Echo-Auszeichung-zurueck-dies-aus-Protest-gegen-die-Auszeichnung-der-umstrittenen-Rapper-Kollegah-und-Farid-Bang.jpg
https://www.blick.ch/life/reisen/fernweh/afrika/abenteuer-in-suedafrika-auf-du-und-du-mit-nashorn-und-gnu-id8238876.html
https://f1.blick.ch/img/incoming/origs4810503/8631372270-w30-h960-q95/AppIcon60x60.png
https://www.blick.ch/people-tv/tv/tatort/
https://www.blick.ch/news/ausland/armenien-armenischer-ministerpraesident-tritt-nach-protesten-zurueck-id8291306.html
https://www.blick.ch/life/wissen/menschen/
https://www.blick.ch/wetter/schweiz/luzern
https://www.blick.ch/sport/eishockey/nla/highlights/
https://www.blick.ch/news/ausland/travis-reinking-29-glaubte-taylor-swift-wuerde-ihn-stalken-die-irre-welt-des-nashville-schuetzen-id8288730.html
https://www.blick.ch/digital/
https://www.blick.ch/auto/abgefahren/mit-dem-vw-amarok-in-oman-im-pritschenwagen-durch-die-wueste-id8281345.html
https://www.blick.ch/sport/leichtathletik/
https://www.blick.ch/sport/fussball/wm/
https://www.blick.ch/news/politik/us-botschafter-mcmullen-im-interview-donald-trump-ist-ein-guter-mensch-id8285369.html
https://www.blick.ch/gewinnen/wir-verlosen-5-ms-sports-fussballcamp-plaetze-kicker-lager-fuer-die-kleinsten-id8279719.html
https://www.blick.ch/sport/fussball/
https://www.blick.ch/services/datenschutzbestimmung-id151553.html
https://www.blick.ch/storytelling/2018/allergie/index.html
https://f2.blick.ch/img/incoming/crop8289178/2794855490-cpanorama-w980-h414-q90/TT-8288254-TT-Rindlisbacher-Suff-Fahrt-quer.jpg
https://www.blick.ch/news/ausland/syrien-konflikt-im-newsticker-die-aktuellen-ereignisse-im-ueberblick-id8241170.html
https://www.blick.ch/sport/fussball/superleague/
https://www.blick.ch/news/schweiz/ostschweiz/schweizer-56-wollte-gesunkenen-raddampfer-besichtigen-taucher-stirbt-im-bodensee-id8289653.html
https://www.blick.ch/life/gesundheit/medizin/
https://www.blick.ch/sport/golf/
https://www.blick.ch/people-tv/royals/es-ist-ein-junge-william-und-kates-drittes-baby-ist-da-id8171954.html
https://f3.blick.ch/img/news/crop7643159/4355579846-chorizontal-w168-h94/Die-Transplantation-einer-Niere.jpg
https://www.blick.ch/people-tv/royals/markles-sexszene-in-suits-ist-schuld-zwischen-meghan-und-kate-herrscht-eiszeit-id8265007.html
https://www.blick.ch/news/politik/russen-in-der-schweiz-die-karawane-zieht-weiter-id8285775.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);