$re = '/^(.+\n)+\n(?!\n)/';
$str = 'test
test2
test3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);