$re = '/\A[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*\n{2,}[^\S\n]*\S.*(?:\n[^\S\n]*\S.*)*/m';
$str = 'Santa Marta is a very special city on the Caribbean Sea in the north of Colombia! It is such a unique place because it was the first Spanish settlement in Colombia and in all of South America!
There are so many magical beaches around here so today I decided to explore one called Taganga! I have no clue what to expect today!!
Let\'s get the adventure started!
test
test
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);