package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bb(([a-z]*)(ea)+)([a-z]*)\b`)
var str = `beast beast bread backseat baccalaureate berate blendable aboreal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}