$re = '/\S.*\K--.*/m';
$str = '-- BOL
test; -- C1
test => -- C1
-- BOL indent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);