re = /^Garage.*(?:[^C].{3}|C[^a].{2}|Ca[^r].{1}|Car[^s])$/m
str = 'GarageTestCars
GaraFail
GarageQual'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end