re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?!.* )(?=.*[^a-zA-Z0-9]).{8,16}$/m
str = 'Jtuhn
12J@k
jok
Joan 12@45
Jghf2@45
Joan=?j123j
@bobblebubble
sasd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end