re = /https?:\/\/(?:www\.)?blibli\.com/m
str = 'https://www.blibli.com/member/p/quest?appsWebview=true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end