$re = '/(?<=\s)(?=\S)|(?<=\S)(?=\s)/u';
$str = 'Hello World »';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);