#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)<a\s+href="(?:https?:\/\/)?(?:w{3}\.)?(?:[^"\/]*\.)?([a-z0-9_-]+\.[a-z0-9_-]{2,6})(\/[^"]*)?"[^>]*>(?!.*\1.*)(?:https?:\/\/)?(?:w{3}\.)?(?:[^"\/]*\.)?([a-z0-9_-]+\.[a-z0-9_-]{2,6})(\/[^"]*)?.*?<\/a>"
Local $sString = "<a href="http://www.test1.net/dir1/index.html" target="_blank">test1.net/admin</a> <-- NOT MATCH" & @CRLF & _
"<a href="https://test2.com">THIS SITE</a> <-- NOT MATCH" & @CRLF & _
"<a href="https://subdomain.test3.org">test2.org</a> <-- MATCH" & @CRLF & _
"<a href="http://www2.test4.com" target="_blank">https://global.test4.com/index.html</a> <-- NOT MATCH" & @CRLF & _
"<a href="http://eu.test5.com">https://evil.com/eu.test5.com/</a> <-- MATCH" & @CRLF & _
"<a href="http://eu.site6.com/index.html" target="_blank">https://eu.evil.com</a> <-- MATCH" & @CRLF & _
"<a href="https://site7.com/">http://www.site7.com/123/test</a> <-- NOT MATCH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")