#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^([A-Z]{2}\s*\d{4})\s+([^\n]+?)(\d+-?\d*\s+cr\.)$(.*?)(?=^[A-Z]{2}\s*\d{4}\s+[^\n]+?\d+-?\d*\s+cr\.$|\Z)"
Local $sString = "VC1000 Venture Capital 4 cr." & @CRLF & _
"This is a class about venture capital" & @CRLF & _
"and more description, that could mention a future course like" & @CRLF & _
"VC2000 but might not" & @CRLF & _
"VC2000 venture capital II 4 cr." & @CRLF & _
"Another description about blah" & @CRLF & _
"VC 3000 venture capital III 4-6 cr." & @CRLF & _
"back again"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")