$re = '/\'[^;]*\'(?=;|$)|([^;]+)(?=;|$)/';
$str = 'Oh yeah this;input;\'with quotes\';can;\'be very\';tricky;\'believe me\';boy;\'\';father\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);