$re = '/\[COLOR=[^]]*?\](.*?)\[\/COLOR\]/mi';
$str = '[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);