import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(?<!_)(?<![a-zA-z])string(?!\\d)(?!_)(?![a-zA-Z])";
final String string = "module mpi_hello_world\n"
+ " use mpi\n"
+ " implicit none\n"
+ "contains\n"
+ " subroutine hello_world(size, & ! testtest\n"
+ " & r_ank, &!\n"
+ " & myhostname &\n"
+ " & )\n"
+ "! this is a comment\n"
+ " ! this also\n"
+ " integer, intent(in) :: size, rank23, rank_er,ranking, myrank, my2r_ank\n"
+ " character(len = *), intent(out) :: myhostname\n\n"
+ " integer :: stat\n"
+ " \n"
+ " myhostname = \"(no host name)\"\n"
+ "#ifdef __INTEL_COMPILER\n"
+ " call get_environment_variable(\"COMPUTERNAME\", myhostname)\n"
+ "#else\n"
+ " stat = hostnm(myhostname)\n"
+ "#endif \n\n"
+ " write(*, *) \"Hello world FORTRAN rank:\", rank, \" size:\", size, &\n"
+ " & \"hostname:\", trim(myhostname)\n"
+ " \n"
+ " end subroutine hello_world\n"
+ "end module mpi_hello_world\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}