$re = '/(?<=.)(?=.$)/m';
$str = 'Jan104aca';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;