$re = '~AT\s\K\pL+~m';
$str = 'AD
Andorra
AT
Austria
BY
Belarus';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);