import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!!)\\[(?=[^\\]]*[a-z])([a-zA-Z_]+[\\w]+)\\]";
final String string = "<?php\n"
+ "$options[$list[_capture_me]][]=array($list[_captureme],$list[_capture_me]);\n"
+ " $option_names[$list[_capture_me]]=$list[_captureme];\n"
+ " $product_name=$list[capture_me];\n"
+ "$product_name=$list[0];\n"
+ "$product_name=$list[DONTCAPTUREME];\n"
+ "$product_name=$list[CapTureMe];\n"
+ "$product_name=$list[CapTurEME];\n"
+ " $actionKey = $get[DONT_CAPTURE_ME];\n\n"
+ " if(array_key_exists(DONT_CAPTURE_ME,$get)) {\n"
+ " $actionKey = $get[DONT_CAPTURE_ME];\n"
+ " if(array_key_exists($actionKey,$this->arrPageActions)){\n"
+ " $this->arrAllTemplatesAndAttributes[$templateID][captureme]['Capture_Me'][$res[option_values_id]] = $res[DONT_CAPTURE_ME];\n"
+ "$old_faq_id.=\"$result[faq_id]&\"; \n"
+ " $result['toc']=\"<b><a href=$PHP_SELF#$result[faq_id]>$result['question']</a></b>\";}\n"
+ " $result['toc']=\"<b><a href=$PHP_SELF#$result[faq_id]>$result[QUESTION]</a></b>\";}\n"
+ "$login_groups_id = $check_admin[login_groups_id];\n"
+ "?>\n\n"
+ "<!--[if lt IE 7]> <html class=\"no-js lt-ie9 lt-ie8 lt-ie7\"> <![endif]-->\n\n"
+ "function check_input(field_name, field_size, message) {\n"
+ " if ($elements[capture_me] && (form.elements[dont_capture].type != \"hidden\") && $form.elements[capture_me]) {\n"
+ " var field_value = form.elements[dontcapure].value;\n"
+ " var field_value = $form.elements[capureme].value;\n\n"
+ " if (field_value == '' || field_value.length < field_size) {\n"
+ " error_message = error_message + \"* \" + message + \"\\n\";\n"
+ " error = true;\n"
+ " }\n"
+ " }\n"
+ "}";
final String subst = "['\\1']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}