import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BindableProperty\\.Create<[a-zA-Z]+,\\s*?([a-zA-Z]+)>\\s*?\\(\\s*?[a-zA-Z]+\\s*=\\>\\s*?[a-zA-Z]+\\.([a-zA-Z]*),\\s*?([a-zA-Z0-9\\s\\(\\)]+(\\.[a-zA-Z]){0,})\\)";
final String string = "\n"
+ " public static BindableProperty FontStyleProperty =\n"
+ " BindableProperty.Create<Button, FontStyle>(p => p.FontStyle, FontStyle.Regular);\n\n"
+ " public static BindableProperty DisabledTextColorProperty =\n"
+ " BindableProperty.Create<Button, Color>(p => p.DisabledTextColor, Color.Default);\n\n"
+ " public static BindableProperty DisabledBackgroundColorProperty =\n"
+ " BindableProperty.Create<Button, Color>(p => p.DisabledBackgroundColor, Color.Default);\n\n"
+ " public static BindableProperty CornerRadiusProperty =\n"
+ " BindableProperty.Create<Button, Thickness>(p => p.CornerRadius, 0);\n\n"
+ " public static BindableProperty ImageHeightProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.ImageHeight, new PointSize(20));\n\n"
+ " public static BindableProperty BackgroundImageProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.BackgroundImage, null);\n\n"
+ " public static BindableProperty HighlightedBackgroundImageProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.HighlightedBackgroundImage, null);\n\n"
+ " public static BindableProperty BackgroundImagePatternProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.BackgroundImagePattern, null);\n\n"
+ " public static BindableProperty HighlightedBackgroundImagePatternProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.HighlightedBackgroundImagePattern, null);\n\n"
+ " public static BindableProperty ImageLeftProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.ImageLeft, null);\n\n"
+ " public static BindableProperty SelectedImageLeftProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.SelectedImageLeft, null);\n\n"
+ " public static BindableProperty ImageTopProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.ImageTop, null);\n\n"
+ " public static BindableProperty ImageRightProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.ImageRight, null);\n\n"
+ " public static BindableProperty ImageBottomProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.ImageBottom, null);\n\n"
+ " public static BindableProperty SelectedImageRightProperty =\n"
+ " BindableProperty.Create<Button, FileImageSource>(p => p.SelectedImageRight, null);\n\n"
+ " public static BindableProperty PaddingProperty =\n"
+ " BindableProperty.Create<Button, Thickness>(p => p.Padding, 0);//DefaultPadding);\n\n"
+ " public static BindableProperty TextPaddingProperty =\n"
+ " BindableProperty.Create<Button, Thickness>(p => p.TextPadding, DefaultTextPadding);\n\n"
+ " public static BindableProperty ImageRightHeightProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.ImageRightHeight, Double.NaN);\n\n"
+ " public static BindableProperty ImageRightWidthProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.ImageRightWidth, Double.NaN);\n\n"
+ " public static BindableProperty ImageLeftHeightProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.ImageLeftHeight, Double.NaN);\n\n"
+ " public static BindableProperty ImageLeftWidthProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.ImageLeftWidth, Double.NaN);\n\n"
+ " public static BindableProperty TiltEnabledProperty =\n"
+ " BindableProperty.Create<Button, bool>(p => p.TiltEnabled, false);\n\n"
+ " public static BindableProperty CenterImageProperty =\n"
+ " BindableProperty.Create<Button, bool>(p => p.CenterImage, false);\n\n"
+ " public static BindableProperty RefitTextEnabledProperty =\n"
+ " BindableProperty.Create<Button, bool>(p => p.RefitTextEnabled, false);\n\n"
+ " public static BindableProperty MinimumFontSizeProperty =\n"
+ " BindableProperty.Create<Button, double>(p => p.MinimumFontSize, new PointSize(8));\n\n"
+ " public static BindableProperty TextLineBreakModeProperty =\n"
+ " BindableProperty.Create<Button, LineBreakMode>(p => p.TextLineBreakMode, LineBreakMode.MiddleTruncation);\n\n"
+ " public static BindableProperty XAlignProperty =\n"
+ " BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.XAlign, Xamarin.Forms.TextAlignment.Center);\n\n"
+ " public static BindableProperty YAlignProperty =\n"
+ " BindableProperty.Create<Button, Xamarin.Forms.TextAlignment>(p => p.YAlign, Xamarin.Forms.TextAlignment.Center);\n\n\n"
+ " public static BindableProperty BorderlessProperty =\n"
+ " BindableProperty.Create<Button, bool>(p => p.Borderless, false);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}