#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}(?!\d)"
Local $sString = "9999 999 9999" & @CRLF & _
"01 999 9999" & @CRLF & _
"+234 1 999 9999" & @CRLF & _
"9999-999-9999" & @CRLF & _
"99999999999" & @CRLF & _
"234 999 999 9999" & @CRLF & _
"234(999)999-9999" & @CRLF & _
"234(999)999 9999" & @CRLF & _
"+234(999)999 9999" & @CRLF & _
"+234(999) 999 9999" & @CRLF & _
"+234(999)999-9999" & @CRLF & _
"2349999999999" & @CRLF & _
"+2349999999999" & @CRLF & _
"" & @CRLF & _
"99999999999fwaefdfs234(999)999-9999" & @CRLF & _
"" & @CRLF & _
"At most 11 digits long (any number combo, excluding the static parts)" & @CRLF & _
"Optional (234) or (+234)" & @CRLF & _
"Optional 1 or 01 or 234 1" & @CRLF & _
"Optional bracketing as specified above."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")