$re = '/(?s)\b(\w+)\b(?=.+\b\1\b)/m';
$str = 'foo bar baz nice abc bla baz nice';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);