using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^<>{}\n]*(?:(?:<[^<>\n]*>|{[^{}\n]*})+[^<>{}\n]*)*$";
string input = @"XXX<XX{X}XXX>X
X{X}X<X>X{X}X<X>X
XXX<X<XX>>XX
XX<XX{XX>XX}XX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}