$re = '/^0*(\d+(?:\.(?:(?!0+$)\d)+)?)/m';
$str = '0.0
1.230
00123
012.30400
0102
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);