#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>DETAILS[\s\S]*|(<p>.*?<\/p>)|.*"
Local $sString = "<info>" & @CRLF & _
"<owner>" & @CRLF & _
"<p>Owners:</p>" & @CRLF & _
"<p>1. New Owner_1</p>" & @CRLF & _
"<p>2. New Owner_2</p>" & @CRLF & _
"</owner>" & @CRLF & _
"<addons>" & @CRLF & _
"<p>Name of dog: Alex</p>" & @CRLF & _
"<p>1. Text blah blah blah</p>" & @CRLF & _
"<p>2. Text blah blah blah</p>" & @CRLF & _
"<p>3. Text blah blah blah</p>" & @CRLF & _
"<p>4. Text blah blah blah</p>" & @CRLF & _
"<p>OR MORE Text blah blah blah</p>" & @CRLF & _
"</addons>" & @CRLF & _
"<p>DETAILS</p>" & @CRLF & _
"<p>1. Vicky Mears 1st dog's owner.</p>" & @CRLF & _
"<p>2. Paul Nash 2nd dog's owner.</p>" & @CRLF & _
"<p>3. Dog found last Apr. 2016</p>" & @CRLF & _
"</info>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")