$re = '/^(?:(?!{{2}).|{{2}(?:dog|cat)}{2})+$/m';
$str = 'I own a {{dog}} and {{cat}} but not fish
I own a fish
I own a {{cow}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);