# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(([a-z] ){3,5}|[a-z]{3,5}) ?\d[\d\- ]{3,15}\d\b|\b\d[\d -]{3,18}\d\b"
test_str = ("my shipment CSD12345678.\n"
"check CAS 1234567 please\n"
"let's try C A S 123-456-789 for me\n"
"or it should be MULTI12345678 forever\n"
"it is 123454677!\n"
"it is COE 123454677!\n"
"superMULTI 12345678 25 two\n"
"twenty symbols code iss 00123456781234567890")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.