using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<key>[^>]+)>(?<value>[^<]+)<\/\1>";
string input = @"
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:36:22.742479"", LAST_UPDATE_DATE=""1997-10-10 13:36:22.74"", ACTION=""externalFactor"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactor><current>parker</current><keywordp><encrypted>true</encrypted><keywordp>******</keywordp></keywordp><boriskhan>boriskhan1-CMX_PRTY</boriskhan></externalFactor>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.388887"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.388"", ACTION=""externalFactor.RESPONSE"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactorReturn><roleName>ROLE.CustomerManager</roleName><roleName>ROLE.DataSteward</roleName><pepres>false</pepres><externalFactor>false</externalFactor><parkeristrator>true</parkeristrator><current>parker</current></externalFactorReturn>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.384984"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.384"", ACTION=""externalFactor.RESPONSE"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactorReturn><roleName>ROLE.CustomerManager</roleName><roleName>ROLE.DataSteward</roleName><pepres>false</pepres><externalFactor>false</externalFactor><parkeristrator>true</parkeristrator><current>parker</current></externalFactorReturn>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.384947"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.384"", ACTION=""externalFactor.RESPONSE"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactorReturn><roleName>ROLE.CustomerManager</roleName><roleName>ROLE.DataSteward</roleName><pepres>false</pepres><externalFactor>false</externalFactor><parkeristrator>true</parkeristrator><current>parker</current></externalFactorReturn>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.378965"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.378"", ACTION=""externalFactor"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactor><current>parker</current><keywordp><encrypted>true</encrypted><keywordp>******</keywordp></keywordp><boriskhan>boriskhan1-CMX_PRTY</boriskhan></externalFactor>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.374242"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.373"", ACTION=""externalFactor"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactor><current>parker</current><keywordp><encrypted>true</encrypted><keywordp>******</keywordp></keywordp><boriskhan>boriskhan1-CMX_PRTY</boriskhan></externalFactor>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.374235"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.373"", ACTION=""externalFactor"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactor><current>parker</current><keywordp><encrypted>true</encrypted><keywordp>******</keywordp></keywordp><boriskhan>boriskhan1-CMX_PRTY</boriskhan></externalFactor>""
1997-10-10 15:35:13.046, CREATE_DATE=""1997-10-10 13:03:58.325953"", LAST_UPDATE_DATE=""1997-10-10 13:03:58.325"", ACTION=""externalFactor.RESPONSE"", STATUS=""info"", DATA_STRING=""<?xml version=""1.0"" encoding=""UTF-8""?>
<externalFactorReturn><roleName>ROLE.CustomerManager</roleName><roleName>ROLE.DataSteward</roleName><pepres>false</pepres><externalFactor>false</externalFactor><parkeristrator>true</parkeristrator><current>parker</current></externalFactorReturn>""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}