using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<text>.*?)(?P<index>{ *{ *([^}{]+?) *} *})";
string input = @"Мы вынуждены отталкиваться от того, что высокотехнологичная концепция общественного уклада обеспечивает актуальность{{1}}приоритизации разума над эмоциями. В своём стремлении повысить качество жизни, они забывают,{ {1}} что семантический разбор внешних противодействий, в своём классическом представлении, допускает внедрение стандартных подходов. В своём стремлении повысить качество жизни, они забывают, что современная методология разработки создаёт необходимость включения в производственный план целого ряда{{1} } внеочередных мероприятий с учётом комплекса кластеризации усилий. Непосредственные участники технического прогресса ограничены исключительно образом мышления. Каждый из нас понимает очевидную вещь: { {1 7 7} }выбранный нами инновационный путь способствует подготовке и реализации приоритизации разума над эмоциями.{{ 1} }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}