$re = '/(?:[^\\\\])(~(.+?)(?:[^\\\\])~)(?:.*?)/';
$str = 'Lorem \\~ ipsum \\~ (~ текст 123 sdf ~) dolor sit amet, consectetur
adipiscing elit [~fullname~] ~noname~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);