$re = '/(?<=Releases\\\\)\w+\\\\/';
$str = 'C:\\Users\\Peter\\Dropbox\\Doing\\RD\\Releases';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);