use strict;
my $str = '{"meta": {"limit": 20, "next": "/api/v1/player/?apikey=Oke2O77ErEgcVgO9MlcK&order_by=tag&format=json&limit=20&offset=20060", "offset": 20040, "previous": "/api/v1/player/?apikey=Oke2O77ErEgcVgO9MlcK&order_by=tag&format=json&limit=20&offset=20020", "total_count": 23321}, "objects": [{"aliases": ["ThomeBrazil"], "birthday": null, "country": "BR", "current_rating": {"decay": 97, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9847516, "rating": 0.0663471472957368, "rating_vp": -0.0467208520402949, "rating_vt": -0.00752417591216662, "rating_vz": 0.0542450279524615, "resource_uri": "/api/v1/rating/9847516/", "tot_vp": 0.019626295255441906, "tot_vt": 0.058822971383570184, "tot_vz": 0.1205921752481983}, "current_teams": [], "dom_end": "/api/v1/period/85/", "dom_start": "/api/v1/period/84/", "dom_val": -1.99400744664177, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 18569, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/18569/", "romanized_name": null, "sc2e_id": null, "tag": "Thome", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "NO", "current_rating": {"decay": 111, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9836061, "rating": -0.0179319625232256, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9836061/", "tot_vp": -0.0179319625232256, "tot_vt": -0.0179319625232256, "tot_vz": -0.0179319625232256}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -1.98857180833208, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 22052, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "R", "resource_uri": "/api/v1/player/22052/", "romanized_name": null, "sc2e_id": null, "tag": "Thommath", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "DE", "current_rating": {"decay": 362, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9842932, "rating": -0.0102069799601648, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9842932/", "tot_vp": -0.0102069799601648, "tot_vt": -0.0102069799601648, "tot_vz": -0.0102069799601648}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -0.536609904167293, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 8938, "lp_name": null, "mcnum": null, "name": "Thomas Ohms", "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/8938/", "romanized_name": null, "sc2e_id": null, "tag": "ThOmMy", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "NL", "current_rating": {"decay": 308, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9836685, "rating": -0.0872791747257656, "rating_vp": 0.0195595477026604, "rating_vt": 0.0, "rating_vz": -0.0195595477026604, "resource_uri": "/api/v1/rating/9836685/", "tot_vp": -0.0677196270231052, "tot_vt": -0.0872791747257656, "tot_vz": -0.106838722428426}, "current_teams": [], "dom_end": "/api/v1/period/35/", "dom_start": "/api/v1/period/34/", "dom_val": -0.978469196608721, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 4537, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/4537/", "romanized_name": null, "sc2e_id": null, "tag": "Thoms", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "KR", "current_rating": {"decay": 324, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9847298, "rating": 0.222665606834311, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9847298/", "tot_vp": 0.222665606834311, "tot_vt": 0.222665606834311, "tot_vz": 0.222665606834311}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -0.643502643189907, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 6434, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/6434/", "romanized_name": "Han Sae", "sc2e_id": null, "tag": "ThomYorke", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["ThorSmash"], "birthday": null, "country": "US", "current_rating": {"decay": 22, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9841554, "rating": -0.0566801820938926, "rating_vp": 0.00665480094052275, "rating_vt": 0.0, "rating_vz": -0.00665480094052275, "resource_uri": "/api/v1/rating/9841554/", "tot_vp": -0.050025381153369845, "tot_vt": -0.0566801820938926, "tot_vz": -0.06333498303441534}, "current_teams": [], "dom_end": "/api/v1/period/124/", "dom_start": "/api/v1/period/123/", "dom_val": -2.40840076973604, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 21258, "lp_name": null, "mcnum": 3, "name": null, "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/21258/", "romanized_name": null, "sc2e_id": null, "tag": "Thor", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 66}, {"aliases": [], "birthday": null, "country": "CU", "current_rating": {"decay": 137, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9832012, "rating": -0.0268222387999633, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9832012/", "tot_vp": -0.0268222387999633, "tot_vt": -0.0268222387999633, "tot_vz": -0.0268222387999633}, "current_teams": [], "dom_end": "/api/v1/period/28/", "dom_start": "/api/v1/period/27/", "dom_val": -1.88361580638791, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 19624, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/19624/", "romanized_name": null, "sc2e_id": null, "tag": "Thor", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "US", "current_rating": {"decay": 116, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9844685, "rating": -0.00164383019479343, "rating_vp": 0.0107166098317799, "rating_vt": 0.00956947025462502, "rating_vz": -0.0202860800864049, "resource_uri": "/api/v1/rating/9844685/", "tot_vp": 0.00907277963698647, "tot_vt": 0.00792564005983159, "tot_vz": -0.02192991028119833}, "current_teams": [], "dom_end": "/api/v1/period/266/", "dom_start": "/api/v1/period/265/", "dom_val": -1.94342772016576, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 3462, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "Z", "resource_uri": "/api/v1/player/3462/", "romanized_name": null, "sc2e_id": null, "tag": "Thor", "tlpd_db": 2, "tlpd_id": 3698, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "AU", "current_rating": {"decay": 339, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9837997, "rating": 0.0184998997211782, "rating_vp": -0.00739192658520421, "rating_vt": 0.0, "rating_vz": 0.00739192658520421, "resource_uri": "/api/v1/rating/9837997/", "tot_vp": 0.011107973135973991, "tot_vt": 0.0184998997211782, "tot_vz": 0.025891826306382412}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -0.769989631020834, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 7570, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/7570/", "romanized_name": null, "sc2e_id": null, "tag": "Thor", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "CA", "current_rating": {"decay": 324, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9843145, "rating": -0.011162991186145, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9843145/", "tot_vp": -0.011162991186145, "tot_vt": -0.011162991186145, "tot_vz": -0.011162991186145}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -0.877331241210363, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 2094, "lp_name": null, "mcnum": null, "name": "Keenan Davreux", "past_teams": [{"end": null, "id": 3956, "playing": true, "resource_uri": "", "start": null, "team": {"id": 278, "name": "Imperative Gaming", "resource_uri": "/api/v1/team/278/", "shortname": "iGx"}}], "race": "P", "resource_uri": "/api/v1/player/2094/", "romanized_name": null, "sc2e_id": null, "tag": "ThoR", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "HU", "current_rating": {"decay": 16, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9832931, "rating": -0.0884545888815071, "rating_vp": -0.0225467479770713, "rating_vt": 0.0158333788175861, "rating_vz": 0.00671336915948521, "resource_uri": "/api/v1/rating/9832931/", "tot_vp": -0.11100133685857841, "tot_vt": -0.072621210063921, "tot_vz": -0.08174121972202189}, "current_teams": [], "dom_end": "/api/v1/period/184/", "dom_start": "/api/v1/period/183/", "dom_val": -2.38952519310069, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 17090, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/17090/", "romanized_name": null, "sc2e_id": null, "tag": "ThorDrop", "tlpd_db": null, "tlpd_id": null, "total_earnings": 20}, {"aliases": [], "birthday": null, "country": "DK", "current_rating": {"decay": 229, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9837125, "rating": 0.124206991437776, "rating_vp": 0.0636386327365573, "rating_vt": 0.0242885556642779, "rating_vz": -0.0879271884008352, "resource_uri": "/api/v1/rating/9837125/", "tot_vp": 0.18784562417433331, "tot_vt": 0.1484955471020539, "tot_vz": 0.0362798030369408}, "current_teams": [], "dom_end": "/api/v1/period/105/", "dom_start": "/api/v1/period/104/", "dom_val": -1.30444861225217, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 1811, "lp_name": "", "mcnum": 2, "name": "Thor Bagge", "past_teams": [{"end": "2013-11-03", "id": 1938, "playing": true, "resource_uri": "", "start": "2013-09-03", "team": {"id": 168, "name": "Karnage eSports", "resource_uri": "/api/v1/team/168/", "shortname": "Karnage"}}, {"end": "2014-03-27", "id": 2054, "playing": true, "resource_uri": "", "start": "2013-11-03", "team": {"id": 140, "name": "Copenhagen Wolves", "resource_uri": "/api/v1/team/140/", "shortname": "Wolves"}}, {"end": "2016-03-07", "id": 4323, "playing": true, "resource_uri": "", "start": "2014-03-27", "team": {"id": 168, "name": "Karnage eSports", "resource_uri": "/api/v1/team/168/", "shortname": "Karnage"}}, {"end": "2017-12-01", "id": 4427, "playing": true, "resource_uri": "", "start": "2016-03-08", "team": {"id": 248, "name": "Dead Pixels", "resource_uri": "/api/v1/team/248/", "shortname": "dPix"}}], "race": "Z", "resource_uri": "/api/v1/player/1811/", "romanized_name": "", "sc2e_id": null, "tag": "Thorminator", "tlpd_db": null, "tlpd_id": null, "total_earnings": 235}, {"aliases": [], "birthday": null, "country": "PL", "current_rating": {"decay": 181, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9850588, "rating": -0.0272212648822163, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9850588/", "tot_vp": -0.0272212648822163, "tot_vt": -0.0272212648822163, "tot_vz": -0.0272212648822163}, "current_teams": [], "dom_end": "/api/v1/period/29/", "dom_start": "/api/v1/period/28/", "dom_val": -1.69642892189747, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 16028, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/16028/", "romanized_name": null, "sc2e_id": null, "tag": "Thorn", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["Kiara"], "birthday": null, "country": "FR", "current_rating": {"decay": 191, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9841288, "rating": -0.00543066671062438, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9841288/", "tot_vp": -0.00543066671062438, "tot_vt": -0.00543066671062438, "tot_vz": -0.00543066671062438}, "current_teams": [], "dom_end": "/api/v1/period/28/", "dom_start": "/api/v1/period/27/", "dom_val": -1.64062153672086, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 15146, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/15146/", "romanized_name": null, "sc2e_id": null, "tag": "Thorn", "tlpd_db": 0, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "DE", "current_rating": {"decay": 235, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9846036, "rating": -0.0489850949362806, "rating_vp": -0.00955634032338923, "rating_vt": 0.0, "rating_vz": 0.00955634032338923, "resource_uri": "/api/v1/rating/9846036/", "tot_vp": -0.05854143525966983, "tot_vt": -0.0489850949362806, "tot_vz": -0.03942875461289137}, "current_teams": [], "dom_end": "/api/v1/period/27/", "dom_start": "/api/v1/period/26/", "dom_val": -1.3897088765712, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 11905, "lp_name": null, "mcnum": 3, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/11905/", "romanized_name": null, "sc2e_id": null, "tag": "Thorontir", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "CA", "current_rating": {"decay": 122, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9831873, "rating": -0.00875380700025146, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9831873/", "tot_vp": -0.00875380700025146, "tot_vt": -0.00875380700025146, "tot_vz": -0.00875380700025146}, "current_teams": [], "dom_end": "/api/v1/period/27/", "dom_start": "/api/v1/period/26/", "dom_val": -1.95723718792886, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 21292, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "P", "resource_uri": "/api/v1/player/21292/", "romanized_name": null, "sc2e_id": null, "tag": "ThorQc", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "US", "current_rating": {"decay": 122, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9835574, "rating": 0.00802768300395641, "rating_vp": 0.0, "rating_vt": 0.0, "rating_vz": 0.0, "resource_uri": "/api/v1/rating/9835574/", "tot_vp": 0.00802768300395641, "tot_vt": 0.00802768300395641, "tot_vz": 0.00802768300395641}, "current_teams": [], "dom_end": "/api/v1/period/27/", "dom_start": "/api/v1/period/26/", "dom_val": -1.94045569792465, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 21059, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "R", "resource_uri": "/api/v1/player/21059/", "romanized_name": null, "sc2e_id": null, "tag": "ThorSmash", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "DE", "current_rating": null, "current_teams": [], "dom_end": null, "dom_start": null, "dom_val": null, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 18361, "lp_name": "", "mcnum": null, "name": "", "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/18361/", "romanized_name": "", "sc2e_id": null, "tag": "ThorTripa", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": [], "birthday": null, "country": "FR", "current_rating": {"decay": 107, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9838246, "rating": -0.108438743684165, "rating_vp": -0.0041489373676717, "rating_vt": 0.0125266598861172, "rating_vz": -0.00837772251844552, "resource_uri": "/api/v1/rating/9838246/", "tot_vp": -0.11258768105183671, "tot_vt": -0.0959120837980478, "tot_vz": -0.11681646620261052}, "current_teams": [], "dom_end": "/api/v1/period/43/", "dom_start": "/api/v1/period/42/", "dom_val": -2.08351251465609, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 21111, "lp_name": null, "mcnum": null, "name": null, "past_teams": [], "race": "T", "resource_uri": "/api/v1/player/21111/", "romanized_name": null, "sc2e_id": null, "tag": "ThorvaldAs", "tlpd_db": null, "tlpd_id": null, "total_earnings": 0}, {"aliases": ["Yakero"], "birthday": "1991-02-09", "country": "SE", "current_rating": {"decay": 230, "dev": 0.16, "dev_vp": 0.16, "dev_vt": 0.16, "dev_vz": 0.16, "id": 9848277, "rating": 0.571713034561594, "rating_vp": 0.0526386003659907, "rating_vt": 0.0416083659545031, "rating_vz": -0.0942469663204938, "resource_uri": "/api/v1/rating/9848277/", "tot_vp": 0.6243516349275846, "tot_vt": 0.6133214005160971, "tot_vz": 0.47746606824110016}, "current_teams": [], "dom_end": "/api/v1/period/164/", "dom_start": "/api/v1/period/163/", "dom_val": -0.778203026776236, "form": {"P": [0, 0], "T": [0, 0], "Z": [0, 0], "total": [0, 0]}, "id": 139, "lp_name": "ThorZaIN", "mcnum": 1, "name": "Marcus Eklöf", "past_teams": [{"end": null, "id": 297, "playing": true, "resource_uri": "", "start": "2012-05-18", "team": {"id": 40, "name": "Evil Geniuses", "resource_uri": "/api/v1/team/40/", "shortname": "EG"}}, {"end": "2010-11-03", "id": 466, "playing": true, "resource_uri": "", "start": "2010-06-18", "team": {"id": 71, "name": "Online Kingdom", "resource_uri": "/api/v1/team/71/", "shortname": "OK"}}, {"end": "2011-05-07", "id": 467, "playing": true, "resource_uri": "", "start": "2010-11-03", "team": {"id": 72, "name": "Praetoriani", "resource_uri": "/api/v1/team/72/", "shortname": "Prae"}}, {"end": "2012-05-09", "id": 492, "playing": true, "resource_uri": "", "start": "2011-05-07", "team": {"id": 22, "name": "mousesports", "resource_uri": "/api/v1/team/22/", "shortname": "mouz"}}], "race": "T", "resource_uri": "/api/v1/player/139/", "romanized_name": null, "sc2e_id": 97, "tag": "ThorZaIN", "tlpd_db": 3, "tlpd_id": 1795, "total_earnings": 98047}]}';
my $regex = qr#{"aliases":\s+.*?,\s+(?:"birthday":\s+(?:null)?)?(?:"birthday":\s+"(.*?)")?,\s+.*?},\s+"id":\s+(\d+?),\s+"lp_name":\s+.*?,\s+"tag":\s+"(.+?)",#mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}