$re = '/(?<=status:\s)(\w+)/m';
$str = 'Hello, this is status: ok
Hello, this is status: ok.
Hello, this is status: ok and I like it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);