import re
regex = re.compile(r"(?<=[IO]\d{3})(\w{12})", flags=re.MULTILINE)
test_str = ("2:O5641057130214TESTBIC34XXX26264938281302141757N\n"
"2:I101YOURBANKXJKLU3003")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")