re = /Birthday\s*(.*)(Age\s(.*))\s*Gender\s*(.*)|Birthday\s*(.*)\s*Gender\s*(.*)/
str = 'Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male
Birthday April 4, 1994
Gender Male'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end