import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<log_time>[\\dT\\-\\:]+)\\s+(?P<log_host>[\\w\\-]+)(?:\\.[\\w\\-\\.]*\\s+|\\s+)(?P<log_type>\\w+)\\s+(?:(?=\\()\\((?P<log_module>[^\\)]+)\\)\\s+|)(?:(?=\\[)\\[(?P<log_tenant>[^ ]+)\\]\\s+|)(?P<log_message>.+)";
final String string = "2017-10-18T12:30:00-04:00 machine.domain.net INFO (Timer-24) [12@MACHINE;;] com.vmware.horizon.connector.admin.StateService - Saving state config to disk DONE.\n"
+ "2017-10-18T12:30:02-04:00 machine.domain.net INFO (Timer-12) [2@MACHINE;;] com.vmware.horizon.dirsync.SyncController - ========== BEGIN SYNC [LIVE RUN] ==========\n"
+ "2017-10-18T12:31:19-04:00 machine INFO pkinit[3753]: closing down fd 12\n"
+ "2017-10-17T15:55:32-04:00 machine.domain.net INFO (SimpleAsync TaskExecutor-2052) [2@MACHINE;;] com.vmware.horizon.connector.utils.RestClient - END sendRequestBase (https://workspaceone.domain.net/SAAS/t/MACHINE/jersey/manager/api/connectormanagement/connectors/11111111-2222-3333-4444-555555555555/syncalerts, ..., application/vnd.vmware.horizon.manager.connector.directory.sync.alerts+json, POST, null, ...)\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}