$re = '/( |^)([A-Z]{1,2})( |$)/m';
$str = 'I ABCDE FGH IG KLMNOPQ RS T';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);