#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@@.*(?:[\s\r]?(?!\s*\^).*)*"
Local $sString = "^0001 HeadOne" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@@" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been theindustry's standard dummy text ever since the 1500s, when an unknown printer took a galley of typeand scrambled it to make a type specimen book." & @CRLF & _
"" & @CRLF & _
"^0002 HeadTwo" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@@" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been theindustry's standard dummy text ever since the 1500s, when an unknown printer took a galley of typeand scrambled it to make a type specimen book." & @CRLF & _
"" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been theindustry's standard dummy text ever since the 1500s, when an unknown printer took a galley of typeand scrambled it to make a type specimen book." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^004 HeadFour" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@@" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book." & @CRLF & _
"" & @CRLF & _
"^0004 HeadFour" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@@" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been theindustry's standard dummy text ever since the 1500s, when an unknown printer took a galley of typeand scrambled it to make a type specimen book." & @CRLF & _
"" & @CRLF & _
"Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been theindustry's standard dummy text ever since the 1500s, when an unknown printer took a galley of typeand scrambled it to make a type specimen book."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")