#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(24180|27268|3696|17532)(?!.*\1)\s+\d+\s+\w+\s+\K\w+"
Local $sString = "2024-04-14 04:56:56.714-0300 24180 20660 UI at64_1 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
"2024-04-14 04:56:56.714-0300 27268 31992 UI at64_4 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
"2024-04-14 04:56:56.714-0300 3696 20128 UI at64_3 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
"2024-04-14 04:56:56.765-0300 3696 20128 UI at64_3 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
"2024-04-14 04:56:56.765-0300 27268 31992 UI at64_4 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
"2024-04-14 04:56:56.765-0300 17532 1384 UI at64_2 [Ready] W: Retrying to obtain clipboard." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")