$re = '/[\d+]{1,2}(,)/';
$str = '11 or 11,11, 11.11 or -1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);