# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(START)(?=.*END)|\G(?!^))((?:(?!START|END)(?>\\+\"|[^\r\n\"]))*)\"/$1$2\\"/gm;t' <<< "This \" is START an \" example input END string \"\"
START This is a \"\" second example END
This\" is \"a START third example END \" \"
START This is a \"\"\\"\"\\\\\\"\"\" test \"\" test\\" second example END \" and more \"\"\"\" END \""