$re = '/ab([^a]|a[^b])*?cd/';
$str = 'start ab0 ab1 aab2 cd kkkk cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);