import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?<DATE>.*)\" (?<SUBJECT>.*) \\(\\((?<FROM>.*)\\)\\) \\(\\((?<SENDER>.*)\\)\\) \\(\\((?<REPLYTO>.*)\\)\\) (?<TO>NIL|\\(.*\\)) (?<CC>NIL|\\(.*\\)) (?<BCC>NIL|\\(.*\\)) (?<RID>NIL|\".*\") (?<MID>NIL|.*)";
final String string = "\"Thu, 10 Mar 2016 14:40:39 -0800\" \"New Site TWR\" ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL \"<009501d17b1d$f404d340$dc0e79c0$@lincsat.com>\"\n\n"
+ "\"Tue, 15 Mar 2016 16:57:10 -0700\" \"From Nicola (touch wood)\" ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((\"Nicola Finch\" NIL \"onearth\" \"lincsat.com\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL \"<003c01d17f16$7a685140$6f38f3c0$@lincsat.com>\"\n\n"
+ "\"Sun, 10 Apr 2016 11:15:46 -0400\" \"REVISION to price lists\" ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) NIL NIL NIL NIL \"<57BA5443-8119-4902-B9B5-CE08183285AA@gsaspirits.com>\"\n\n"
+ "\"Tue, 12 Apr 2016 01:17:18 -0400\" \"muskoka flood petition to get the water down\" ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"TML Councillors and Mayor\" NIL \"TMLcouncillorsmayor\" \"rogers.com\")(\"DMM Councillors\" NIL \"districtcouncillors311\" \"muskoka.on.ca\")(\"bala merchants & residents\" NIL \"balamerchantsetal\" \"rogers.com\")(\"Michael Hart Pres M.L.A.\" NIL \"mla1hart\" \"aol.com\")(\"MRA Directors\" NIL \"directors\" \"muskokaratepayers.ca\")(\"MRA attn Liz Denyar\" NIL \"muskokaratepayers\" \"vianet.ca\")(\"torrance merchants & residents\" NIL \"torrancemerchants&res\" \"rogers.com\")(\"TML C of C board members & GM\" NIL \"mlcofcboard\" \"rogers.com\")(\"minister MNRF bill mauro\" NIL \"minister.mnr\" \"ontario.ca\")(\"MNRF PS Dist Mgr Dan Duggan\" NIL \"dan.duggan\" \"ontario.ca\")(\"MNRF Anne Collins\" NIL \"anne.collins\" \"ontario.ca\")(\"mactier merchants & res\" NIL \"mactiermerchsetal\" \"rogers.com\")(\"wahta mohawks including senior administrator K. Commandant\" NIL \"wahtamohawks\" \"rogers.com\")(\"port carling merchants & res\" NIL \"pcmerchsetal\" \"rogers.com\")(\"bracebridge merchants & res\" NIL \"bracebridgemerchsetal\" \"rogers.com\")) ((\"gravenhurst merchs & res\" NIL \"gravenhurstmerchsetal\" \"rogers.com\")(\"Muskoka Tourism Board Members\" NIL \"MTMA311\" \"muskoka.com\")(\"Huntsville Merchants & res\" NIL \"huntsvillemerchtsres\" \"rogers.com\")(\"Rosseau merchs and res\" NIL \"rosseaumerchsres\" \"rogers.com\")(\"parry sound merchants & res\" NIL \"psmerchsetal\" \"rogers.com\")(\"catherine Nasmith Pres ACO, Ontario\" NIL \"ns1catherine\" \"aol.com\")(\"walkers point residents\" NIL \"walkerspointresidents\" \"rogers.com\")(\"PNP cottagers residents\" NIL \"pnpcottagersresidents\" \"rogers.com\")(\"MP Tony Clement\" NIL \"Clement.T\" \"parl.gc.ca\")(\"mpp norm miller\" NIL \"norm.miller\" \"pc.ola.org\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL \"\"\n\n"
+ "\"Thu, 14 Apr 2016 11:52:42 -0400\" Scotch Order Reminder ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) ((\"GSA Spirits\" NIL \"jan\" \"gsaspirits.com\")) NIL NIL NIL NIL \"<300492E2-6E2A-4B20-9315-6838EE7BE12B@gsaspirits.com>\"\n\n"
+ "\"Thu, 21 Apr 2016 12:37:20 -0400\" \"Emailing: MLA Water Level media release Apr 20 2016\" ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"Balamo Conservation Corporation\" NIL \"balamocc\" \"gmail.com\")) ((\"bala merchants & residents\" NIL \"balamerchantsetal\" \"rogers.com\")(\"wahta mohawks including senior administrator K. Commandant\" NIL \"wahtamohawks\" \"rogers.com\")(\"torrance merchants & residents\" NIL \"torrancemerchants&res\" \"rogers.com\")(\"mactier merchants & res\" NIL \"mactiermerchsetal\" \"rogers.com\")(\"port carling merchants & res\" NIL \"pcmerchsetal\" \"rogers.com\")(\"bracebridge merchants & res\" NIL \"bracebridgemerchsetal\" \"rogers.com\")(\"Huntsville Merchants & res\" NIL \"huntsvillemerchtsres\" \"rogers.com\")(\"gravenhurst merchs & res\" NIL \"gravenhurstmerchsetal\" \"rogers.com\")(\"walkers point residents\" NIL \"walkerspointresidents\" \"rogers.com\")(\"PNP cottagers residents\" NIL \"pnpcottagersresidents\" \"rogers.com\")) ((\"Premier Wynne con Exec Asst/Off Mgr aafaaq shaikh\" NIL \"kwynne.mpp.co\" \"liberal.ola.org\")(\"MP Tony Clement\" NIL \"Clement.T\" \"parl.gc.ca\")(\"MP DV West Rob Oliphant\" NIL \"rob.oliphant\" \"parl.gc.ca\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL \"\"\n\n"
+ "\"Thu, 21 Apr 2016 13:54:30 -0400\" \"Re: Yonge St S\" ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL \"<20160421160107.CD1DE1777CB@relay1.esolutionsgroup.ca>\" \"<98BF5417-E6CA-4C16-B80B-6648CD8F5C53@gmail.com>\"\n\n"
+ "\"Wed, 27 Apr 2016 10:32:51 -0700\" \"Your payment to Ontario Disc Sports Association\" ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<1461778371.1018@paypal.com>\"\n\n"
+ "\"Wed, 27 Apr 2016 22:03:38 -0700 (PDT)\" \"Thank You for Registering for the Black Fly Fling\" ((\"Chris Shier\" NIL \"shier10\" \"hotmail.com\")) ((\"Chris Shier\" NIL \"shier10\" \"hotmail.com\")) ((NIL NIL \"shier10\" \"hotmail.com\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"\"\n\n"
+ "\"Wed, 27 Apr 2016 22:05:03 -0700\" \"Your payment to Chris Shier- Disc Golf Tournament Director\" ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"service@intl.paypal.com\" NIL \"service\" \"intl.paypal.com\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<1461819903.17653@paypal.com>\"\n\n"
+ "\"Sat, 07 May 2016 11:32:05 +0000\" Re: Thanks for your Disc Golf club memberships in ODSA ((\"Chris Ozolins\" NIL \"chris\" \"ondisc.org\")) ((\"Chris Ozolins\" NIL \"chris\" \"ondisc.org\")) ((\"Chris Ozolins\" NIL \"chris\" \"ondisc.org\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"\"\n\n"
+ "\"Thu, 12 May 2016 15:27:20 -0400\" \"Confirmation email for processed transaction.\" ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL NIL\n\n"
+ "\"Thu, 12 May 2016 15:40:38 -0400\" \"Welcome to Bronze Membership, Kevin!\" ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL NIL\n\n"
+ "\"Thu, 12 May 2016 15:40:40 -0400\" \"Confirmation email for processed payment on existing invoice.\" ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL NIL\n\n"
+ "\"Thu, 12 May 2016 16:38:05 -0400\" \"Confirmation email for processed transaction.\" ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((NIL NIL \"kevin\" \"ecms.io\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL NIL\n\n"
+ "\"Sat, 14 May 2016 12:19:45 -0400\" \"Black Fly Fling Player Information Package\" ((\"Chris Shier\" NIL \"shier10\" \"hotmail.com\")) ((\"Chris Shier\" NIL \"shier10\" \"hotmail.com\")) ((\"Chris Shier\" NIL \"shier10\" \"hotmail.com\")) NIL NIL NIL NIL \"\"\n\n"
+ "\"Mon, 16 May 2016 15:46:04 -0400\" \"Re: Yonge St S\" ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((\"Bob Stone\" NIL \"bobstonexx\" \"gmail.com\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL \"<20160421160107.CD1DE1777CB@relay1.esolutionsgroup.ca>\" \"<15291B6E-64E0-4ED3-9D24-08555912ECB7@gmail.com>\"\n\n"
+ "\"Sun, 29 May 2016 11:29:42 -0400\" \"Recital Tickets\" ((\"Jacqueline Farley\" NIL \"jackie\" \"ecms.io\")) ((\"Jacqueline Farley\" NIL \"jackie\" \"ecms.io\")) ((NIL NIL \"jackie\" \"ecms.io\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<39ef40f5-6529-4749-037d-84f60f5012c3@ecms.io>\"\n\n"
+ "\"Wed, 1 Jun 2016 12:54:32 -0400 (EDT)\" \"Reminder: Ontario car insurance rates just dropped!\" ((\"The Lowest Rates Team\" NIL \"info\" \"lowestrates.email\")) ((NIL NIL \"mailer\" \"infusionmail.com\")) ((\"The Lowest Rates Team\" NIL \"info\" \"lowestrates.email\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<1535672484.1343451464800072503.JavaMail.tomcat@phxcw4>\"\n\n"
+ "\"Wed, 1 Jun 2016 20:01:13 +0000\" \"RE: Auto quote\" ((\"Wendy Bossence\" NIL \"wendy.bossence.qxm8\" \"statefarm.com\")) ((\"Wendy Bossence\" NIL \"wendy.bossence.qxm8\" \"statefarm.com\")) ((\"Wendy Bossence\" NIL \"wendy.bossence.qxm8\" \"statefarm.com\")) ((\"KEVIN@BARRENS.CA\" NIL \"KEVIN\" \"BARRENS.CA\")) NIL NIL \"\" \"<5CC46A4110FA61438C5FC101BC5F425824A9255C@WPSDGQGD.OPR.STATEFARM.ORG>\"\n\n"
+ "\"Thu, 02 Jun 2016 21:17:57 -0400\" Fwd: Black Sails : Fact or Fiction ((\"Jacqueline Farley\" NIL \"jackie\" \"barrens.ca\")) ((\"Jacqueline Farley\" NIL \"jackie\" \"barrens.ca\")) ((\"Jacqueline Farley\" NIL \"jackie\" \"barrens.ca\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL \"\" \"\"\n\n"
+ "\"Thu, 23 Jun 2016 19:49:25 +0000\" \"=?utf-8?Q?Exclusive=20offer=21=20Best=20rates=20this=20summer=20at=20Clevelands=20House?=\" ((\"=?utf-8?Q?Muskoka=20Tourism?=\" NIL \"info\" \"muskokatourism.ca\")) ((\"Muskoka Tourism\" NIL \"info=muskokatourism.ca\" \"mail30.wdc01.mcdlv.net\")) ((\"=?utf-8?Q?Muskoka=20Tourism?=\" NIL \"info\" \"muskokatourism.ca\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"\"\n\n"
+ "\"Mon, 4 Jul 2016 17:12:04 -0400\" RE: Request a quote (Epson PowerLite Home Cinema 5030UB projector FullHD 3D 1080p) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL \"\" \"<046B370B7DE8514B977FF287BF6BCBCB0148FE50F0F3@QASERVER1.qacoustic.local>\"\n\n"
+ "\"Tue, 05 Jul 2016 11:36:30 -0400\" \"You can get big money out of politics\" ((\"Amy Watson, Green Party of Ontario\" NIL \"amywatson\" \"gpo.ca\")) ((\"Amy Watson, Green Party of Ontario\" NIL \"amywatson\" \"gpo.ca\")) ((\"Amy Watson, Green Party of Ontario\" NIL \"amywatson\" \"gpo.ca\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<20160705153631.1C222CA8194@civismtp.uas.coop>\"\n\n"
+ "\"Tue, 5 Jul 2016 19:10:42 -0400\" RE: Request a quote (Epson PowerLite Home Cinema 5030UB projector FullHD 3D 1080p) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Richard Desjardins\" NIL \"richard\" \"quebecacoustic.com\")) ((\"Kevin Farley\" NIL \"kevin\" \"barrens.ca\")) NIL NIL \"<9e93217e-89b8-3d1a-c35a-4ceb33398519@barrens.ca>\" \"<046B370B7DE8514B977FF287BF6BCBCB0148FE50F107@QASERVER1.qacoustic.local>\"\n\n"
+ "\"Wed, 6 Jul 2016 13:43:09 +0000\" \"Eastporters : Price request for Epson 5030UB PowerLite Home Cinema 1080P 3D Home Theater Projector\" ((\"Eastporters Audio Video\" NIL \"sales\" \"eastporters.com\")) ((\"Eastporters Audio Video\" NIL \"sales\" \"eastporters.com\")) ((NIL NIL \"sales\" \"eastporters.com\")) ((NIL NIL \"kevin\" \"barrens.ca\")) NIL NIL NIL \"<62fee33070cbfcb4599d530b644c5e73@www.eastporters.com>\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}