package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ab`)
var str = `abc
acb
ab123 ab456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}