package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bunder`)
var str = `understand
underworld
Underworld
TheUnderworld`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}