$re = '/\s/m';
$str = '1237 Main Street,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);