package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w{2,5}`)
var str = `1237 Main Street,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}